Welcome Guest, Login or Sign up

Spell check language from body

By: lfasci

This extension determines language for spell check from the message.It installs text_cat and replaces the default aspell.php. When a user select spell check, aspell.php determines the language passing the message body to text_cat .This works on zcs 6 and zcs 7.  For detail about text_cat see http://odur.let.rug.nl/~vannoord/TextCat/.

Installation: copy the zip on the server with zimbra_aspell installed, unzip, as root run install.sh

 

Update:

1.1 -> 1.2: Changed  compression formato to tgz, changed install.sh.

1.2 -> 1.3: Changed  aspell.php to avoid syntax error calling TextCat, it works on zcs 7.1


Download

Rating ( 4 ratings )
Downloads 4971
Latest Version 1.3
Categories Mail , Translations , Utilities
Compatibility ZCS Legacy
License No License Specified
Created on 2/22/11
Updated on 10/4/15

Reviews

  • Works on Zimbra 8.0.x ? 

    By: baudinpr on on 5/22/13 for version 1.3

    Hi all,can be installed on Zimbra 8.0.x?Does it work also on webclient ? ThanksPieroB

  • Works but needs some additional languages 

    By: mvanderkruk on on 2/1/12 for version 1.3

    I succesfully installed the package om ZCS 7.1.4.Only noticed that dutch was not a supported /recognized language.After adding the dutch language to the $languages arry in the aspell.php file it works perfectly. Perhaps a good addition for a following version => inclusion of more languages which can be recognized.

  • Works on ZCS 7 

    By: adrian.gibanel.btactic on on 3/31/11 for version 1.2

    This extension works on ZCS 7. Actually spell.php file from original ZCS 6 and original ZCS 7 are the same ones.I have commented the two last lines on install script and it works, you do not need to chown zimbra:zimbra the aspell installation.

  • Need help 

    By: ted04 on on 3/20/11 for version 1.2

    The installation was easy but it's not working as expected. How can I check the functionality?Please help.Thanks.

     
    • If you installed the 1.0 release, please intall the new 1.2. Bye 

      Replied on 3/21/11